
<!doctype html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
	<meta name="referrer" content="no-referrer-when-downgrade"/>
	
	<!-- This site is optimized with the Yoast SEO Premium plugin v17.7 (Yoast SEO v17.7.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Insta360 Go 2 Review: Too Many Compromises</title>
	<meta name="description" content="The Insta360 Go 2 is a tiny camera that&#039;s surprisingly capable of a lot, but lacks crucial features like expandable storage and 4K." />
	<link rel="canonical" href="https://www.premiumbeat.com/blog/insta360-go-2-review/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Insta360 Go 2 Review: Too Many Compromises" />
	<meta property="og:description" content="The Insta360 Go 2 is a tiny camera that&#039;s surprisingly capable of a lot, but lacks crucial features like expandable storage and 4K." />
	<meta property="og:url" content="https://www.premiumbeat.com/blog/insta360-go-2-review/" />
	<meta property="og:site_name" content="The Beat: A Blog by PremiumBeat" />
	<meta property="article:publisher" content="https://www.facebook.com/premiumbeat" />
	<meta property="article:published_time" content="2022-01-18T16:43:05+00:00" />
	<meta property="article:modified_time" content="2022-01-18T16:43:06+00:00" />
	<meta property="og:image" content="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18090956/Insta-360-Go-2-Cover.jpg" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="584" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@Premiumbeat" />
	<meta name="twitter:site" content="@Premiumbeat" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Alejandro Medellin" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="10 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.premiumbeat.com/blog/#website","url":"https://www.premiumbeat.com/blog/","name":"The Beat: A Blog by PremiumBeat","description":"","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.premiumbeat.com/blog/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.premiumbeat.com/blog/insta360-go-2-review/#primaryimage","inLanguage":"en-US","url":"https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18090956/Insta-360-Go-2-Cover.jpg","contentUrl":"https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18090956/Insta-360-Go-2-Cover.jpg","width":1000,"height":584,"caption":"Insta360 Go 2 Review: Too Many Compromises"},{"@type":"WebPage","@id":"https://www.premiumbeat.com/blog/insta360-go-2-review/#webpage","url":"https://www.premiumbeat.com/blog/insta360-go-2-review/","name":"Insta360 Go 2 Review: Too Many Compromises","isPartOf":{"@id":"https://www.premiumbeat.com/blog/#website"},"primaryImageOfPage":{"@id":"https://www.premiumbeat.com/blog/insta360-go-2-review/#primaryimage"},"datePublished":"2022-01-18T16:43:05+00:00","dateModified":"2022-01-18T16:43:06+00:00","author":{"@id":"https://www.premiumbeat.com/blog/#/schema/person/f084de83e29e047fbd7e51a645aa23ad"},"description":"The Insta360 Go 2 is a tiny camera that's surprisingly capable of a lot, but lacks crucial features like expandable storage and 4K.","breadcrumb":{"@id":"https://www.premiumbeat.com/blog/insta360-go-2-review/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.premiumbeat.com/blog/insta360-go-2-review/"]}]},{"@type":"BreadcrumbList","@id":"https://www.premiumbeat.com/blog/insta360-go-2-review/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.premiumbeat.com/blog/"},{"@type":"ListItem","position":2,"name":"Video Gear","item":"https://www.premiumbeat.com/blog/category/video-gear/"},{"@type":"ListItem","position":3,"name":"Insta360 Go 2 Review: Too Many Compromises"}]},{"@type":"Person","@id":"https://www.premiumbeat.com/blog/#/schema/person/f084de83e29e047fbd7e51a645aa23ad","name":"Alejandro Medellin","image":{"@type":"ImageObject","@id":"https://www.premiumbeat.com/blog/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/c705728724f3e8e2c578776c95d6f2eb?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/c705728724f3e8e2c578776c95d6f2eb?s=96&d=mm&r=g","caption":"Alejandro Medellin"},"description":"Alejandro is a North Texas-based writer with a passion for video games, consumer electronics, and computers. He has a degree in journalism from the University of North Texas. @skinny_fats is his Twitter handle.","url":"https://www.premiumbeat.com/blog/author/amedellin/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//cdn.optimizely.com' />
<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="The Beat: A Blog by PremiumBeat &raquo; Feed" href="https://www.premiumbeat.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Beat: A Blog by PremiumBeat &raquo; Comments Feed" href="https://www.premiumbeat.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Beat: A Blog by PremiumBeat &raquo; Insta360 Go 2 Review: Too Many Compromises Comments Feed" href="https://www.premiumbeat.com/blog/insta360-go-2-review/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Beat: A Blog by PremiumBeat &raquo; Stories Feed" href="https://www.premiumbeat.com/blog/web-stories/feed/"><link rel='stylesheet' id='all-css-0' href='https://vip-go.premiumbeat.com/wp-includes/css/dist/block-library/style.min.css?m=1641496683g' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='premiumbeat-thebeatcom-hero-style-inline-css'>
.wp-block-create-block-thebeatcom-hero{background-color:#21759b;color:#fff;padding:2px}

</style>
<style id='premiumbeat-thebeatcom-posts-sidebar-style-inline-css'>
/**
 * The following styles get applied both on the front of your site
 * and in the editor.
 *
 * Replace them with your own styles or remove the file completely.
 */
.wp-block-create-block-thebeatcom-posts-sidebar {
  background-color: #21759b;
  color: #fff;
  padding: 2px;
}

/*# sourceMappingURL=style-index.css.map*/
</style>
<link rel='stylesheet' id='all-css-4' href='https://vip-go.premiumbeat.com/_static/??-eJyNjssOAiEMRX9IYIjO6Mb4LQw0iJZHbInh74WFiZMY46q5vec0Vc8iQrJYHZC6kYrgggGECIk3oaBp8BAI3tgmY0jSEu3UL713n3kj2Zx4MHztHY2xgmGboyJuCH9wnRAuEKsVs/96O1ZRsPqQ+mvAxdi70JOch/leDOcSz3o56NN+Os7LC/x+ZFA=' type='text/css' media='all' />
<script type="text/javascript" src="https://vip-go.premiumbeat.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZiaGJpZmZhXEWAK+SIig=" ></script><script src='https://cdn.optimizely.com/js/2602720526.js?ver=1.0.8' id='thebeatcom-optimizely-js-js'></script>
<script src='https://s7.addthis.com/js/300/addthis_widget.js?ver=1.0.8' defer='defer' id='thebeatcom-s7-addthis-js-js'></script>
<link rel="https://api.w.org/" href="https://www.premiumbeat.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://www.premiumbeat.com/blog/wp-json/wp/v2/posts/162967" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vip-go.premiumbeat.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vip-go.premiumbeat.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://wp.me/pab9JK-Gov' />
<link rel="alternate" type="application/json+oembed" href="https://www.premiumbeat.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.premiumbeat.com%2Fblog%2Finsta360-go-2-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.premiumbeat.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.premiumbeat.com%2Fblog%2Finsta360-go-2-review%2F&#038;format=xml" />

<!-- BEGIN Parse.ly 2.6.1 -->
<meta name="parsely-title" content="Insta360 Go 2 Review: Too Many Compromises" />
<meta name="parsely-link" content="http://www.premiumbeat.com/blog/insta360-go-2-review/" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18090956/Insta-360-Go-2-Cover.jpg?w=150&amp;h=150&amp;crop=1" />
<meta name="parsely-pub-date" content="2022-01-18T16:43:05Z" />
<meta name="parsely-section" content="Video Gear" />
<meta name="parsely-tags" content="action camera,gopro,insta360 go 2,outdoors,video gear" />
<meta name="parsely-author" content="Alejandro Medellin" />
<!-- END Parse.ly -->

<style type='text/css'>img#wpstats{display:none}</style>
		<!-- Google Analytics -->
	<script>
	window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
	ga('create', 'UA-100928-1', 'auto');
	ga('set', 'forceSSL', true);
	ga('send','pageview');
	</script>
	<script async src='https://www.google-analytics.com/analytics.js'></script>
	<!-- End Google Analytics -->
		<link rel="preconnect" href="//p1.parsely.com">
	<link rel="preconnect" href="//connect.facebook.net">
	<link rel="preconnect" href="//www.googletagmanager.com">
	<link rel="preconnect" href="//google-analytics.com">
	<link rel="icon" href="https://pbblogassets.s3.amazonaws.com/uploads/2020/11/10090922/cropped-PB_blog_icon-1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://pbblogassets.s3.amazonaws.com/uploads/2020/11/10090922/cropped-PB_blog_icon-1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://pbblogassets.s3.amazonaws.com/uploads/2020/11/10090922/cropped-PB_blog_icon-1.png?w=180" />
<meta name="msapplication-TileImage" content="https://pbblogassets.s3.amazonaws.com/uploads/2020/11/10090922/cropped-PB_blog_icon-1.png?w=270" />
<style type="text/css" id="wp-custom-css">.blog .post-content .content-main p.image_via { display: none; }</style>
	<script>
		var addthis_config = addthis_config||{};
		addthis_config.data_track_addressbar = false;
		addthis_config.data_track_clickback = false;
		addthis_config.pubid = 'ra-5509cca02b072e5c';
	</script>

	<!-- send a few variables to main.js -->
	<script>
		var PB = window.PB || {};
		PB.env = "prod";

		var pathInfo = {
			base: "https:\/\/vip-go.premiumbeat.com\/wp-content\/themes\/thebeatcom\/",
			css: 'css/',
			js: 'js/',
			swf: 'swf/'
		}
	</script>
</head>
<body class="post-template-default single single-post postid-162967 single-format-standard blog">

<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WCTZ2L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
		new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
		j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
		'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer', "GTM-WCTZ2L" );</script>
<!-- End Google Tag Manager -->

	<div class="wrapper-blog">
				<div id="header-wrapper">
			<header class="header">
	<script type="text/javascript">
		var pbUserId = 0;
	</script>

	<nav class="primary-wrapper">
		<div class="primary-inner">
			<div class="clearfix">
				<a class="logopb" href="https://www.premiumbeat.com/">
					<img src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/logo_white.svg" alt="PremiumBeat logo" width="175" height="43">
				</a>

				<ul class="primary-nav">
					<li class="nav-large
										"> <a href="/royalty_free_music/most_popular" class="js-track-click" data-track-key="navTabClick"><span class="title">music</span></a></li>
					<li class="nav-large
										"><a class="js-track-click active" data-track-key="navTabClick" href="/blog"><span class="title">blog</span></a></li>

				</ul>
				<ul class="tablet-nav tablet-h-show">
					<li><a class='icon btMenu'>
						<span class="open"><img src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/hamburger-menu.svg" width="20" height="16" alt="menu icon"></span>
						<span class="close">T</span>

						</a></li>
				</ul>
			</div>

			<div class="tablet-menu tablet-h-show">
				<div class="table-menu">
					<div class="row-menu">
						<div class="cell-menu first">
							<div class="tablet-main-menu">
								<ul class="clearfix">
									<li>
										<a href="/royalty_free_music/most_popular"  data-track-key="navTabClick" class="js-track-click
																				" href="#">Music</a>
										<div class="trigger_btn">A</div>
										<div class="toggle_container">
											<ul>
												<li><a href="/music/genres">Genres</a></li>
												<li><a href="/music/moods">Moods</a></li>
											</ul>

										</div>
									</li>
									<li>
										<a href="/blog"  data-track-key="navTabClick" class="js-track-click active">Blog</a>
									</li>
								</ul>
							</div>
						</div>
					</div>
					<div class="row-menu">
						<div class="cell-menu last">
							<div class="clearfix">
								<div class="nav-block social">
									<ul>
										<li class="btn-facebook"><a href="https://www.facebook.com/premiumbeat" target="_blank" rel="noreferrer"><span class="normal-rounded-icon icon">e</span></a></li>
										<li class="btn-twitter"><a href="https://twitter.com/#!/premiumbeat" target="_blank" rel="noreferrer"><span class="normal-rounded-icon icon">w</span></a></li>
										<li class="btn-youtube"><a href="https://www.youtube.com/user/premiumbeat" rel="publisher noreferrer" target="_blank"><span class="normal-rounded-icon icon">√</span></a></li>
										<li class="btn-instagram"><a href="https://www.instagram.com/premiumbeat/" rel="publisher noreferrer" target="_blank"><span class="normal-rounded-icon icon">∫</span></a></li>
									</ul>
								</div>
								<div class="security-text">
									<img src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/ico_shopping.svg" width="30" height="25" alt="Security logo" loading="lazy"> 100<sub>%</sub> SECURE SHOPPING
								</div>

								<div class="menu-copyright">
									PremiumBeat.com copyright © 2005-2022 <br />Shutterstock Music Canada ULC All rights reserved.</span>
								</div>
							</div>

						</div>
					</div>
				</div>
			</div>

		</div>
	</nav>
	<!-- cart growl-->
	<div style="display:none;">
		<div class="growl-header-cart">
			<div class="title-holder">
				<span class="icon">5</span>
				<span class="title">Shopping Cart</span>
			</div>
			<div class="text">Your cart has been updated</div>
			<a rel="nofollow" href="/cart" class="bt-normal bt js-checkout">checkout</a>
		</div>
	</div>
	<!-- cart growl-->
</header>
		</div>

	<article class="post-class-post-162967 post-class-post post-class-type-post post-class-status-publish post-class-format-standard post-class-has-post-thumbnail post-class-hentry post-class-category-video-gear post-class-tag-action-camera post-class-tag-gopro post-class-tag-insta360-go-2 post-class-tag-outdoors post-class-tag-video-gear-2">

		<div class="blog-wrapper">
			<div class="logo-thebeat-wrapper">
				<a href="https://www.premiumbeat.com/blog/" title="The Beat">
					<img class="logo-thebeat" src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/TheBeat.svg" alt="The Beat logo" width="200" height="54">
				</a>
			</div>
			<header class="blog-header">
				<div class="inner section-inner">
					<div class="blog-nav  browse collapse">

	<div class="menu-wrapper tablet-h-hide">

		<nav class="menu clearfix">
			<ul class="main-nav">
				<li id="menu-item-144950" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-144950"><a href="https://www.premiumbeat.com/blog/">All</a></li>
<li id="menu-item-144951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144951"><a href="https://www.premiumbeat.com/blog/category/video-editing/">Video Editing</a></li>
<li id="menu-item-144952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144952"><a href="https://www.premiumbeat.com/blog/category/video-production-2/">Video Production</a></li>
<li id="menu-item-144953" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144953"><a href="https://www.premiumbeat.com/blog/category/motion-graphics-2/">Motion Graphics</a></li>
<li id="menu-item-144954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144954"><a href="https://www.premiumbeat.com/blog/category/free-for-video/">Free Downloads</a></li>
<li id="menu-item-144955" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-144955 menu-item-mega-parent"><a href="#">More</a>
<ul class="sub-menu ">
	<li id="menu-item-144956" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-144956 mega-menu-title"><a href="#">Software</a>
	<ul class="sub-menu ">
		<li id="menu-item-144959" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144959 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/after-effects/">After Effects</a></li>
		<li id="menu-item-144960" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144960 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/avid/">Avid</a></li>
		<li id="menu-item-144961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144961 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/cinema-4d/">Cinema 4D</a></li>
		<li id="menu-item-144962" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144962 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/final-cut-pro/">Final Cut Pro</a></li>
		<li id="menu-item-144963" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144963 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/final-cut-pro-x/">Final Cut Pro X</a></li>
		<li id="menu-item-144964" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144964 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/premiere-2/">Premiere Pro</a></li>
		<li id="menu-item-144965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144965 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/davinci-resolve/">DaVinci Resolve</a></li>
		<li id="menu-item-144966" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144966 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/smoke-2/">Smoke</a></li>
	</ul>
</li>
	<li id="menu-item-144957" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-144957 mega-menu-title"><a href="#">Production &#038; Post</a>
	<ul class="sub-menu ">
		<li id="menu-item-144967" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144967 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/color-grading/">Color Grading</a></li>
		<li id="menu-item-144968" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144968 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/filmmaking-2/">Filmmaking</a></li>
		<li id="menu-item-144969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144969 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/industry/">Industry</a></li>
		<li id="menu-item-144970" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144970 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/inspiration/">Inspiration</a></li>
		<li id="menu-item-144971" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144971 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/motion-graphics-2/">Motion Graphics</a></li>
		<li id="menu-item-144972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144972 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/photography/">Photography</a></li>
		<li id="menu-item-144973" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144973 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/tutorials/">Tutorials</a></li>
		<li id="menu-item-144974" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144974 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/video-editing/">Video Editing</a></li>
		<li id="menu-item-144975" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor active current-post-parent menu-item-144975 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/video-gear/">Video Gear</a></li>
	</ul>
</li>
	<li id="menu-item-144958" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-144958 mega-menu-title"><a href="#">Music &#038; Sound Effects</a>
	<ul class="sub-menu ">
		<li id="menu-item-144976" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144976 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/audio-editing-2/">Audio Editing</a></li>
		<li id="menu-item-144977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144977 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/music-copyright/">Music Copyright</a></li>
		<li id="menu-item-144978" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144978 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/premiumbeat-com-composers/">Premiumbeat Composers</a></li>
		<li id="menu-item-144979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144979 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/premiumbeat-news/">PremiumBeat News</a></li>
		<li id="menu-item-144980" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144980 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/royalty-free-music/">Royalty Free Music</a></li>
		<li id="menu-item-144981" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144981 menu-item-mega-link"><a href="https://www.premiumbeat.com/blog/category/sound-effects/">Sound Effects</a></li>
	</ul>
</li>
</ul>
</li>
			</ul>

			<div class="social-box">
					<ul class="social-networks clearfix">
						<li class="btn-facebook"><a class="small-normal-rounded-icon" href="https://www.facebook.com/premiumbeat">e</a></li>
						<li class="btn-twitter"><a class="small-normal-rounded-icon" href="https://www.twitter.com/premiumbeat">w</a></li>
						<li class="btn-youtube"><a class="small-normal-rounded-icon" href="https://www.youtube.com/user/premiumbeat" rel="publisher noreferrer" target="_blank">√</a></li>
					</ul>
			</div>
			<div class="menu-search">
				<div class="menu-search-inner">
					<form method="get" class="search-form search-holder" action="https://www.premiumbeat.com/blog/" >
	<fieldset>
		<input type="search" name="s" placeholder="Search blog" />
		<button class="bt-search" type="submit" value="Search" aria-label="Search"></button>
	</fieldset>
</form>
				</div>
			</div>
		</nav>

	</div> <!-- menu-wrapper -->

	<div class="mobile-menu tablet-h-show clearfix">


		<div class="select-holder">
			<span class="text">Categories</span>
			<div class="project-select">
				<select>
					<option data-cat="https://www.premiumbeat.com/blog/">All</option></li>
<option data-cat="https://www.premiumbeat.com/blog/category/video-editing/">Video Editing</option></li>
<option data-cat="https://www.premiumbeat.com/blog/category/video-production-2/">Video Production</option></li>
<option data-cat="https://www.premiumbeat.com/blog/category/motion-graphics-2/">Motion Graphics</option></li>
<option data-cat="https://www.premiumbeat.com/blog/category/free-for-video/">Free Downloads</option></li>
<option data-cat="#">More</option>	<option data-cat="#">Software</option>		<option data-cat="https://www.premiumbeat.com/blog/category/after-effects/">After Effects</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/avid/">Avid</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/cinema-4d/">Cinema 4D</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/final-cut-pro/">Final Cut Pro</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/final-cut-pro-x/">Final Cut Pro X</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/premiere-2/">Premiere Pro</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/davinci-resolve/">DaVinci Resolve</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/smoke-2/">Smoke</option></li>
	</ul>
</li>
	<option data-cat="#">Production &#038; Post</option>		<option data-cat="https://www.premiumbeat.com/blog/category/color-grading/">Color Grading</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/filmmaking-2/">Filmmaking</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/industry/">Industry</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/inspiration/">Inspiration</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/motion-graphics-2/">Motion Graphics</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/photography/">Photography</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/tutorials/">Tutorials</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/video-editing/">Video Editing</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/video-gear/">Video Gear</option></li>
	</ul>
</li>
	<option data-cat="#">Music &#038; Sound Effects</option>		<option data-cat="https://www.premiumbeat.com/blog/category/audio-editing-2/">Audio Editing</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/music-copyright/">Music Copyright</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/premiumbeat-com-composers/">Premiumbeat Composers</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/premiumbeat-news/">PremiumBeat News</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/royalty-free-music/">Royalty Free Music</option></li>
		<option data-cat="https://www.premiumbeat.com/blog/category/sound-effects/">Sound Effects</option></li>
	</ul>
</li>
</ul>
</li>

				</select>
			</div>
		</div>
		<div class="menu-search">
			<div class="menu-search-inner">
				<form method="get" class="search-form search-holder" action="https://www.premiumbeat.com/blog/" >
	<fieldset>
		<input type="search" name="s" placeholder="Search blog" />
		<button class="bt-search" type="submit" value="Search" aria-label="Search"></button>
	</fieldset>
</form>
			</div>
		</div>
		<div class="social-box">
			<ul class="social-networks clearfix">
				<li class="btn-facebook"><a class="small-normal-rounded-icon" href="https://www.facebook.com/premiumbeat" rel="noreferrer">e</a></li>
				<li class="btn-twitter"><a class="small-normal-rounded-icon" href="https://www.twitter.com/premiumbeat" rel="noreferrer">w</a></li>
				<li class="btn-youtube"><a class="small-normal-rounded-icon" href="https://www.youtube.com/user/premiumbeat" rel="publisher noreferrer" target="_blank">√</a></li>
			</ul>
		</div>

	</div>
</div>
				</div>
			</header>


		
	<main role="main" id="main" class="main">
		<div class="section-inner">
			<article class="post clearfix">


				<header class="post-header">
					<p class="breadcrumbs"><span><span><a href="https://www.premiumbeat.com/blog/">Home</a> » <span><a href="https://www.premiumbeat.com/blog/category/video-gear/">Video Gear</a> » <span class="breadcrumb_last" aria-current="page">Insta360 Go 2 Review: Too Many Compromises</span></span></span></span></p>

				</header>


				<div class="post-content clearfix">



					<div class="content-main">
													<div class="featured-image">
								<img width="865" height="505" src="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18090956/Insta-360-Go-2-Cover.jpg" class="attachment-feature_desktop size-feature_desktop wp-post-image" alt="Insta360 Go 2 Review: Too Many Compromises" loading="lazy" />							</div>
							
															<p class="image_via">Cover image via <a href="" target="_blank"></a></p>
																			<div class="post-header">
							<h1 class="post-title">Insta360 Go 2 Review: Too Many Compromises</h1>
							<div class="author-wrapper">
	
	<div class="author-holder">
		<div><em class="author vcard">By <a href="https://www.premiumbeat.com/blog/author/amedellin/" class="fn">Alejandro Medellin</a></em></div>
		<div><time class="updated published" datetime="2022-01-18"> January 18, 2022</time></div>
	</div>
</div>
							<div class="category-list-wrapper">
								<nav class="category-list">
									<ul>
									<li><a href="https://www.premiumbeat.com/blog/category/video-gear/" rel="category tag">Video Gear</a></li>
									</ul>
								</nav>
								<div class="inline-like-wrapper" style="display:none;">
									<div class="like-wrapper">
	<div class="fb-like" data-layout="button_count" data-action="like" data-show-faces="false" data-share="true"></div>
</div>								</div>
							</div>
						</div>
						<div class="content-main-post">
							
<h2 id="h-the-insta360-go-2-is-a-tiny-camera-that-s-surprisingly-capable-of-a-lot-but-lacks-crucial-features-like-expandable-storage-and-4k">The Insta360 Go 2 is a tiny camera that&#8217;s surprisingly capable of a lot, but lacks crucial features like expandable storage and 4K. </h2>



<p>When placed inside the charge case, the <a href="https://store.insta360.com/product/go_2" target="_blank" rel=" noopener" data-wpel-link="external">Insta360 Go 2</a> is about the size of an AirPods case. It has no business being this good, although there are some caveats—maybe too many caveats.&nbsp;</p>



<p>Ever since the debut of the original <a href="https://www.premiumbeat.com/blog/rise-fall-of-the-gopro/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">GoPro</a>, <a href="https://www.premiumbeat.com/blog/6-cameras-4k-120fps-capturing-slow-motion-sports/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">action cameras</a> have gotten smaller, slimmer, and more powerful. While the <a href="https://www.premiumbeat.com/blog/should-you-carry-go-pro-filmmaking-kit/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">GoPro</a> and similar <a href="https://www.premiumbeat.com/blog/dji-ronin-4d-camera-gimbal-reveal/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">offerings from DJI</a> and <a href="https://www.premiumbeat.com/blog/360-camera-buying-guide/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">Insta360</a> have more or less looked the same for years, the Go 2 is something new. It&#8217;s something different, and it&#8217;s about time. </p>



<p>With a stripped-down display-less user interface and a single button for interaction, the Go 2 is dead simple to use. The compact nature of the camera is its most significant selling point, but it&#8217;s no slouch when it comes to shooting modes or versatility. </p>



<p>All that being said, the miniature camera does compromise on features in the name of compactness, impacting everything from max video quality to storage and accessibility. Individually, the setbacks are minimal for most casual shooters, but if you want the best possible action camera with the best <em>everything</em>, it&#8217;s a harder sell.&nbsp;</p>



<hr class="wp-block-separator"/>



<h2 id="h-small-but-capable">Small but Capable</h2>



<p>Just looking at the Go 2, it&#8217;s safe to say it doesn&#8217;t look like much. The white, oblong design is devoid of any buttons or a display, which is common in other <a href="https://www.premiumbeat.com/blog/underwater-cinematography-action-cam-vs-underwater-rig/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">action cameras</a>. The lens and microphone hole are the only two things that would give you a hint as to what this product does. </p>



<p>Most importantly, since this is an action camera, the Go 2 is waterproof up to thirteen feet. If it wasn&#8217;t, the camera would be useless. However, the camera does more than put up with a dunk in the lake. It also has eight different shooting modes with a max resolution of 2K, or QHD (2,560 x 1,440), and a max frame rate of 50fps. For a camera of this size, those are impressive specs.</p>



<p>If you were a child of the DSLR revolution looking at the specs and then the size of the Go 2, it truly is a testament to the development of camera technology. </p>



<figure class="wp-block-image size-full"><a href="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18092505/Insta-360.jpg" data-wpel-link="external" target="_blank"><img loading="lazy" width="755" height="425" src="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18092505/Insta-360.jpg" alt="A man's hand displays the Insta 360 Go 2" class="wp-image-163031"/></a><figcaption><em>You won&#8217;t find a more miniature action camera.</em> </figcaption></figure>



<p>While using the camera module, you won&#8217;t have access to every shooting mode, but camera functionality can be customized in the app to adjust what the camera can do. The Go 2 may lack an obvious button, but the entire front panel can be clicked. Pressing, double-pressing, or holding the camera button can trigger different actions, depending on whether the camera is on or off. </p>



<p>For example, clicking the camera while <em>off</em> activates video mode immediately. Clicking the button when the camera is already <em>on</em> triggers pro video mode, which shoots video with expanded features such as the camera&#8217;s FlowState stabilization. </p>



<p>There&#8217;s a handy cheat sheet included to help you remember each action, but they can be reconfigured in the app. It can be a little frustrating trying to remember how to trigger each function, but it pays off once you do.&nbsp;</p>



<p>Placing the Go 2 in the charge case expands functionality even further. The screen on the case, while small, can be navigated with the two buttons to choose which mode to shoot in. You can also change camera settings such as <a href="https://www.premiumbeat.com/blog/how-to-export-a-high-resolution-movie-out-of-final-cut-pro-x/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">resolution</a>, <a href="https://www.premiumbeat.com/blog/filmmaking-guide-choosing-aspect-ratio/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">aspect ratio</a>, field of view, and more. Also, it charges the camera and extends battery life up to one hour max.</p>



<hr class="wp-block-separator"/>



<h2 id="h-a-great-value">A Great Value</h2>



<p>The Go 2 is the main attraction, but the product comes with many goodies that expand its usability beyond a <a href="https://www.premiumbeat.com/blog/6-best-filmmaking-cameras-under-1000/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">point-and-shoot camera</a>. You have the charging case for starters, the other half of the Go 2. </p>



<p>When the clam shell case is unfolded, the two legs on the bottom can be extended to use the device like a <a href="https://www.premiumbeat.com/blog/the-best-tripods-for-video-professionals/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">tripod</a>. The charging case also has a 1/4&#8243; -20 mount for attaching to accessories and a convenient USB-C port for charging and data transfer. </p>



<p>If the Go 2 camera module is the entree, the charge case is the bread starter, appetizer, and sides. The dessert? The accessories.&nbsp;</p>



<figure class="wp-block-image size-full"><a href="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18093326/insta360-everything-in-box1-1.jpg" data-wpel-link="external" target="_blank"><img loading="lazy" width="755" height="755" src="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18093326/insta360-everything-in-box1-1.jpg" alt="The Insta 360 Go 2 and its accessories on a white background" class="wp-image-163035"/></a><figcaption><em>Everything that&#8217;s included in the box. Image via <a href="https://store.insta360.com/product/go_2" target="_blank" rel=" noopener" data-wpel-link="external">Insta360</a>.</em></figcaption></figure>



<p>Included with the Go 2: the magnet pendant, easy clip, and pivot stand. The magnetic pendant is arguably the most ridiculous of the bunch, making the camera look like it&#8217;s floating halfway up your torso. It&#8217;s convenient if you don&#8217;t want to worry too much about camera setup when on the trail or bike ride. The use case will vary, and that&#8217;s if you can get over how dorky it looks.&nbsp;</p>



<p>The easy clip is also weird, but in a good way—it&#8217;s much more helpful. The clip attaches to the brim of your hat, and the part that holds the camera rotates up or down. The camera&#8217;s placement is the best way to shoot eye-level POV video. If you create content using your hands to craft or make something, you&#8217;ll want to keep this close by. </p>



<p>The pivot stand is the third and final accessory. It has a sticky base that can be used repeatedly, and the pivot gives it full movement. I stuck it onto the dashboard of a car to capture a time-lapse. It&#8217;s by far the most useful of the three.&nbsp;</p>



<p>Other accessories, such as a selfie stick and GoPro accessory adapters, are sold separately.&nbsp;</p>



<hr class="wp-block-separator"/>



<h2 id="h-the-many-compromises">The Many Compromises&nbsp;</h2>



<figure class="wp-block-image size-full"><a href="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18094601/Insta-360-Go.jpg" data-wpel-link="external" target="_blank"><img loading="lazy" width="755" height="425" src="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18094601/Insta-360-Go.jpg" alt="Insta 360 Go 2 set on a cliff overlooking a canyon and blue skies" class="wp-image-163042"/></a><figcaption><em>The charge case is also a tripod, but it&#8217;s not very reliable. It can easily fall over if not set upright. </em></figcaption></figure>



<p>Aside from the casual user who wants a small, simple camera that&#8217;s ready-to-go at a moment&#8217;s notice, the Go 2 isn&#8217;t for everyone. There are myriad of compromises that do eventually add up. </p>



<p>While no single factor makes it a dealbreaker, the lack of expandable storage is one to consider. Whether you choose the 32GB or 64GB model, you&#8217;ll constantly have to offload media to your phone to keep the storage clear. Not everyone will fill up the camera&#8217;s storage in the span of a single trip, but it&#8217;s a limitation that will keep some adventurers from bringing the camera along. </p>



<p>Speaking of adventure, the Go 2 is waterproof, but the charge case, which adds so much functionality to the camera, is not. When planning to shoot in or near water, your Go 2 will be limited to shooting in only certain conditions.&nbsp;</p>



<h3 id="h-too-hot-to-handle">Too Hot to Handle&nbsp;</h3>



<p>There are claims the Go 2 camera module overheats. I tested the Go2 in the cool Denver climate, so it&#8217;s not something I experienced, but I read several complaints (<a href="https://www.reddit.com/r/Insta360/comments/oyid5p/is_my_go_2_defective_overheating_intense_battery/" target="_blank" rel=" noopener" data-wpel-link="external">like this one</a>) online about the overheating issue.</p>



<p>While mine didn&#8217;t overheat, it was extremely warm to the touch when I used it. When speaking to an Insta360 spokesperson, I was told that the camera being warm to the touch is a common issue due to its small size. It was also brought to my attention that the camera has a way of dissipating heat via the small metal dots on the back. </p>



<p>To prevent overheating, it&#8217;s best not to touch the camera&#8217;s backside and shoot away from direct sunlight. According to Insta360, the camera can operate in max 104 degree weather, while the charge case tops out at 131 degrees. Shooting in warmer conditions will accelerate overheating, so make sure to let the camera rest in-between longer shots in warm weather. </p>



<p>And, if it does overheat, Insta360 says the camera can get back in action after a few minutes of cooling down. I realize the camera overheating is not ideal, but that&#8217;s the tradeoff of a smaller form factor. I experienced a similar issue when <a href="https://www.inputmag.com/reviews/dji-action-2-review-gopro-may-have-met-its-match" target="_blank" rel=" noopener" data-wpel-link="external">I reviewed the DJI Action 2</a>. It&#8217;s an inescapable fact of owning an action camera. </p>



<h3 id="h-no-4k">No 4K</h3>



<figure class="wp-block-gallery columns-2 is-cropped"><ul class="blocks-gallery-grid"><li class="blocks-gallery-item"><figure><a href="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18095919/Insta360-Go-2-unedited.jpg" data-wpel-link="external" target="_blank"><img loading="lazy" width="755" height="425" src="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18095919/Insta360-Go-2-unedited.jpg" alt="Image of a dark canyon with cloudy sky" data-id="163043" data-full-url="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18095919/Insta360-Go-2-unedited.jpg" data-link="https://www.premiumbeat.com/blog/?attachment_id=163043" class="wp-image-163043"/></a><figcaption class="blocks-gallery-item__caption"><em>Shot on Insta360 Go 2 (unedited).</em></figcaption></figure></li><li class="blocks-gallery-item"><figure><a href="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18095930/Insta360-Go-2-edited.jpg" data-wpel-link="external" target="_blank"><img loading="lazy" width="755" height="425" src="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18095930/Insta360-Go-2-edited.jpg" alt="Shot of a canyon in the background and a pavillion with people in the foreground" data-id="163044" data-full-url="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/18095930/Insta360-Go-2-edited.jpg" data-link="https://www.premiumbeat.com/blog/?attachment_id=163044" class="wp-image-163044"/></a><figcaption class="blocks-gallery-item__caption"><em>Shot on the Google Pixel 5a (unedited).</em> </figcaption></figure></li></ul></figure>



<p>The DJI Action 2, however, has much more to offer in terms of resolution. It can shoot in up to 4K at 120fps, which far outdoes what the Insta360 Go 2 can do. With a max QHD resolution (2,560 x 1,440) and 50fps, it&#8217;s suitable at the moment, but feels like it&#8217;s already been left in the dust by competitors. </p>



<p>I don&#8217;t see many people choosing this camera over newer ones with better specs. Like with <em>every </em><a href="https://www.shutterstock.com/blog/sports-photographer-trade-secrets" target="_blank" rel=" noopener" data-wpel-link="external">action camera</a>, the camera is also not good at taking stills. It&#8217;s fine for capturing a quick shot, but the resolution isn&#8217;t optimal for heavy cropping. Applying the camera&#8217;s &#8220;PureShot&#8221; feature will enhance the image, but still, don&#8217;t hold your breath for amazing images.&nbsp;</p>



<h3 id="h-exporting-is-a-mess">Exporting Is a Mess</h3>



<figure class="wp-block-video"><video controls src="https://pbblogassets.s3.amazonaws.com/uploads/2022/01/14131336/20211128_143654_223.mp4"></video><figcaption><em>Notice the watermark? So annoying! </em></figcaption></figure>



<p>Another gripe is that offloading content from the camera is a pain. Exporting to your phone via the Insta360 Go app takes <em>forever</em>. For some reason, exported content gets the brand&#8217;s watermark. The feature is annoyingly set to default, which you can turn off. </p>



<p>On the other hand, offloading to your computer is easier, provided you have the <a href="https://www.insta360.com/download/insta360-go2" target="_blank" rel=" noopener" data-wpel-link="external">Insta360 Studio software</a> downloaded. Without the software, all videos and images have a <a href="https://www.premiumbeat.com/blog/5-affordable-fisheye-lenses-for-small-rooms/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">fish-eye lens</a> effect that has to be individually fixed by zooming in and adjusting lens distortion on your NLE. It&#8217;s another step that I don&#8217;t want to deal with. The software does this automatically and lets you adjust FOV to your liking, at least, and it does let you do some basic clip editing. </p>



<p>But, let&#8217;s be real. You&#8217;re most likely going to offload content to your phone when you need to make more space or post to social media, and that just takes too long. You&#8217;ll miss out on the action when you&#8217;re exporting content, and I wish there was either more storage or a faster way to export. </p>



<hr class="wp-block-separator"/>



<h2 id="h-worth-your-money">Worth Your Money?</h2>



<p>The Insta360 Go 2 is a cute camera that&#8217;s certainly capable of a lot, considering its size. It&#8217;s got <a href="https://youtu.be/ih3UU_ezLrk?t=248" target="_blank" rel=" noopener" data-wpel-link="external">awesome stabilization</a>, a variety of shooting modes, and it&#8217;s incredibly convenient to take with you. But I wouldn&#8217;t recommend it over the DJI Action 2. </p>



<p>The DJI Action is $100 more expensive when comparing base models, but you also have MicroSD card support, a touch screen, additional touchscreen, and backup battery modules, and it can shoot in 4K. The Go 2, on the other hand, has way too many compromises.&nbsp;</p>



<p>If you&#8217;re a casual adventurer with a need for a tiny no-fuss camera, the Go 2 isn&#8217;t a bad pick. But, if you&#8217;re serious about making content, it&#8217;s not enough. Whether it&#8217;s the lack of higher resolution and frame rate, the sub-par exporting process, or limited storage space, the Go 2 leaves much to be desired. </p>



<p>It&#8217;s a fun little camera—there&#8217;s no doubt about it—but I&#8217;d save up for something better like the DJI Action 2, which is much more future-proof.&nbsp;</p>



<hr class="wp-block-separator"/>



<p>PremiumBeat is the one-stop-shot for tips, tricks, and advice. Check out these articles:</p>



<ul><li><a href="https://www.premiumbeat.com/blog/selling-gear-online-resale-outlets/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">Selling Expensive Gear Online? Resale Outlets May Be Your Friend</a></li><li><a href="https://www.premiumbeat.com/blog/nikon-z9-release/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">YouTubers Behold: The New Nikon Z9 (And Why It Doesn’t Really Matter)</a></li><li><a href="https://www.premiumbeat.com/blog/iphone-13-cinematic-mode/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">What Makes the iPhone 13’s Cinematic Mode Cinematic?</a></li><li><a href="https://www.premiumbeat.com/blog/probe-lens-guide/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">Is It Worth Buying a Probe Lens in 2022?</a></li><li><a href="https://www.premiumbeat.com/blog/blackmagic-design-2022/" target="_blank" rel="noreferrer noopener" data-wpel-link="internal">What Could We See from Blackmagic Design in 2022?</a></li></ul>
						</div>
							<div class="content-share">
		<div class="content-share-inner">
			<div class="social-wrapper">
				<div class="social">
					<div class="inner">

					 <!--<div class="item share">
							<div class="icon">7</div>
							<div class="title">Like this article?</div>
						</div>
						<div class="item box-count">
							<span class='st-bt st_fblike_vcount' st_url="https://www.premiumbeat.com/blog/insta360-go-2-review/"></span>
							<span class='st-bt st_facebook_vcount' st_url="https://www.premiumbeat.com/blog/insta360-go-2-review/"></span>
							<span class='st-bt st_plusone_vcount' st_url="https://www.premiumbeat.com/blog/insta360-go-2-review/"></span>
							<span class='st-bt st_twitter_vcount' st_url="https://www.premiumbeat.com/blog/insta360-go-2-review/" st_via=''></span>
					</div> -->

						<div class="at-wrapper">

							<div class="share-cnt">
								<div class="total"></div>
								<div class="text"></div>
							</div>
							<div class="share-bt-wrapper">

								<a class="share-bt facebook addthis_button_facebook">
									<span class="icon">e</span>
								</a>
								<a class="share-bt twitter addthis_button_twitter">
									<span class="icon">w</span>
								</a>

								<!--
								<a class="share-bt google addthis_button_google_plusone_share">
									<span class="icon">q</span>
								</a>
								-->

								<a class="share-bt email addthis_button_email">
									<i class="fa fa-envelope-o" aria-hidden="true"></i>
								</a>
							</div>


						</div>


					</div>
				</div>
			</div>
		</div>
	</div>

					</div>

					<div class="content-related sidebar">
					</div>
				</div>


			</article>
		</div> <!-- section-inner -->
	</main>

	<!-- Default every promo to RS  -->
							
<div class="section-inner">
	<div class="post-promo pb" style="background-color: #2c2c2c">
		<div class="inner">
			<h3 class="title">
				<a class="pb-promo-title" href="">
					Get 70% Off Music <br>Subscribe & Save!				</a>
			</h3>
			<a class="bt bt-big"
			href="https://www.premiumbeat.com/license"
			onClick="_gaq.push(['_trackEvent', 'Blog Callouts to Music', 'In-Post Bottom Callout', 'Need Music for Projects']);">
			Get Started			</a>
			<div class="post-promo-logo"><img class="logo" src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/logo_pb_white_gold.svg" alt="PremiumBeat Logo"></div>
		</div>
	</div>
</div>
		
	<section class="post-info clearfix">
		<div class="section-inner">
						<div class="wrapper-related-title clearfix">
				<div class="bottom-related-title">More articles from this Author</div>
				<div class="equal-height-col">
				
					<div class="related-article-holder col col-1">
												<div class="related-article">
							<div class="related-article-inner">
								<div class="cat-holder">
								<a class="img-holder" href="https://www.premiumbeat.com/blog/elgato-master-mount-system/">

																			<img width="270" height="150" src="https://pbblogassets.s3.amazonaws.com/uploads/2021/11/16084343/Elgatos-Master-Mount-System-Cover.jpg" class="photo wp-post-image" alt="Elgato&#039;s Master Mount System Is a Must-Have Piece of Kit" loading="lazy" />																	</a>
								</div>
								<div class="cat-wrapper">
																												<a class="cat-box" href="/blog/category/product-reviews">
											
												Video Gear
																					</a>
																	 </div>
								<a class="related-title bt" href="https://www.premiumbeat.com/blog/elgato-master-mount-system/" rel="bookmark" title="Elgato&#8217;s Master Mount System Is a Must-Have Piece of Kit">Elgato&#8217;s Master Mount System Is a Must-Have Piece of Kit</a>
								<div class="post-bottom-holder">
									<footer class="holder post-bottom">
										<div class="frame">
											<strong class="author vcard">By <a rel="nofollow" href="https://www.premiumbeat.com/blog/author/amedellin/" class="fn">
											Alejandro Medellin</a></strong>
											<time class="date updated published" datetime="11-16-2021">11-16-2021</time>
										</div>

									</footer>
								</div>
							</div>
						</div>
					</div>

					
					<div class="related-article-holder col col-2">
												<div class="related-article">
							<div class="related-article-inner">
								<div class="cat-holder">
								<a class="img-holder" href="https://www.premiumbeat.com/blog/video-editing-tips-cutting-documentary/">

																			<img width="270" height="150" src="https://pbblogassets.s3.amazonaws.com/uploads/2021/05/20140957/Editing-Documentary.jpg" class="photo wp-post-image" alt="14 Video Editing Tips for Cutting a Documentary Film" loading="lazy" />																	</a>
								</div>
								<div class="cat-wrapper">
																												<a class="cat-box" href="/blog/category/filmmaking-2">
											
												Filmmaking
																					</a>
																	 </div>
								<a class="related-title bt" href="https://www.premiumbeat.com/blog/video-editing-tips-cutting-documentary/" rel="bookmark" title="14 Video Editing Tips for Cutting a Documentary">14 Video Editing Tips for Cutting a Documentary</a>
								<div class="post-bottom-holder">
									<footer class="holder post-bottom">
										<div class="frame">
											<strong class="author vcard">By <a rel="nofollow" href="https://www.premiumbeat.com/blog/author/amedellin/" class="fn">
											Alejandro Medellin</a></strong>
											<time class="date updated published" datetime="05-24-2021">05-24-2021</time>
										</div>

									</footer>
								</div>
							</div>
						</div>
					</div>

					
					<div class="related-article-holder col col-3">
												<div class="related-article">
							<div class="related-article-inner">
								<div class="cat-holder">
								<a class="img-holder" href="https://www.premiumbeat.com/blog/tips-for-using-lumafusion/">

																			<img width="270" height="150" src="https://pbblogassets.s3.amazonaws.com/uploads/2021/05/10134944/LumaFusion-Feature.jpg" class="photo wp-post-image" alt="Top 10 Things I Wish I Knew Before Using LumaFusion" loading="lazy" />																	</a>
								</div>
								<div class="cat-wrapper">
																												<a class="cat-box" href="/blog/category/audio-editing-2">
											
												Video Editing
																					</a>
																	 </div>
								<a class="related-title bt" href="https://www.premiumbeat.com/blog/tips-for-using-lumafusion/" rel="bookmark" title="Top 10 Things I Wish I Knew Before Using LumaFusion">Top 10 Things I Wish I Knew Before Using LumaFusion</a>
								<div class="post-bottom-holder">
									<footer class="holder post-bottom">
										<div class="frame">
											<strong class="author vcard">By <a rel="nofollow" href="https://www.premiumbeat.com/blog/author/amedellin/" class="fn">
											Alejandro Medellin</a></strong>
											<time class="date updated published" datetime="05-13-2021">05-13-2021</time>
										</div>

									</footer>
								</div>
							</div>
						</div>
					</div>

					
					<div class="related-article-holder col col-4">
												<div class="related-article">
							<div class="related-article-inner">
								<div class="cat-holder">
								<a class="img-holder" href="https://www.premiumbeat.com/blog/canon-camera-best-webcam/">

																			<img width="270" height="150" src="https://pbblogassets.s3.amazonaws.com/uploads/2020/05/22125842/EOS-80D-Video-Creator-Kit_1_l-1.jpg" class="photo wp-post-image" alt="Canon Camera Just Became the Best Webcam You Own" loading="lazy" />																	</a>
								</div>
								<div class="cat-wrapper">
																												<a class="cat-box" href="/blog/category/tutorials">
											
												Video Gear
																					</a>
																	 </div>
								<a class="related-title bt" href="https://www.premiumbeat.com/blog/canon-camera-best-webcam/" rel="bookmark" title="Your Canon Camera Just Became the Best Webcam You Own">Your Canon Camera Just Became the Best Webcam You Own</a>
								<div class="post-bottom-holder">
									<footer class="holder post-bottom">
										<div class="frame">
											<strong class="author vcard">By <a rel="nofollow" href="https://www.premiumbeat.com/blog/author/amedellin/" class="fn">
											Alejandro Medellin</a></strong>
											<time class="date updated published" datetime="04-16-2021">04-16-2021</time>
										</div>

									</footer>
								</div>
							</div>
						</div>
					</div>

								</div>
		</div>
					</div>
	</section>

	
				</div> <!-- blog-wrapper -->
			</article>
			<footer class="footer">
		<section class="footer-nav">
				<div class="email-bg">
						<div class="email-table">
								<div class="email-cell">
										<div class="mobile-email">
												<div class="section-inner clearfix">


														<div class="email-wrapper">

																<div class="title-holder">
																		<p>Experience the <br class="mobile-display">best <br><span>TheBeat</span> <br class="mobile-display">has to offer.</p>
																</div>
																<!-- Begin MailChimp Signup Form -->
																<div class="newsletter-signup">
																		<div id="mc_embed_signup">
																				<form id="newsletter-form" action="https://audioapipb.shutterstock.com/v1/premiumbeat/newsletter" method="put" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
																						<div id="mc_embed_signup_scroll">
																								<div class="input-wrapper">

																										<div class="mc-field-group cell email">
																												<input type="email" value="" name="EMAIL" class="dark required email" id="mce-EMAIL" placeholder="Your Email">
																										</div>
																								</div>
																								<div id="mce-responses" class="clear">
																										<div class="response" id="mce-error-response" style="display:none"></div>
																										<div class="response" id="mce-success-response" style="display:none"></div>
																								</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
																								<div style="position: absolute; left: -5000px;"><input type="text" name="b_542fde17ee1ccbec98dd7f656_a6d760ba52" tabindex="-1" value=""></div>
																								<div class="clear bt-holder">
																										<input type="submit" value="Subscribe Now" name="subscribe" id="mc-embedded-subscribe" class="bt-new-medium">
																								</div>
																						</div>
																				</form>
																		</div>
																</div>
																<!--End mc_embed_signup-->
														</div>

												</div>
										</div>

								</div>
						</div>
				</div>
				<div class="section-inner clearfix">
						<div class="wrapper-footer-nav">
							<ul class="footer-sidebars">
								<li id="nav_menu-3" class="widget widget_nav_menu nav-block general"><h5 class="title">General</h5><div class="menu-footer-area-1-container"><ul id="menu-footer-area-1" class="menu"><li id="menu-item-144125" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144125"><a href="https://www.premiumbeat.com/">Home</a></li>
<li id="menu-item-144126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144126"><a href="/royalty-free-music">Royalty Free Music</a></li>
<li id="menu-item-144127" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144127"><a href="/royalty-free-music-genre">Music Genres</a></li>
<li id="menu-item-144128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144128"><a href="/royalty-free-music-mood">Music Moods</a></li>
<li id="menu-item-144129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144129"><a href="/music-instrument">Music Instruments</a></li>
<li id="menu-item-144130" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144130"><a href="/artists">Artists</a></li>
<li id="menu-item-144131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144131"><a href="/royalty-free-tracks">Songs</a></li>
<li id="menu-item-144132" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144132"><a href="https://rocketstock.com/after-effects-templates/">After Effects Templates</a></li>
<li id="menu-item-144133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144133"><a href="https://www.shutterstock.com/video/">Stock Video</a></li>
<li id="menu-item-144134" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144134"><a href="/stock-music">Stock Music</a></li>
<li id="menu-item-144135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144135"><a href="https://www.shutterstock.com/photos">Stock Photos</a></li>
</ul></div></li><li id="nav_menu-4" class="widget widget_nav_menu nav-block music"><h5 class="title">Collections</h5><div class="menu-footer-area-2-container"><ul id="menu-footer-area-2" class="menu"><li id="menu-item-144136" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144136"><a href="/royalty-free-music">Most Popular Music</a></li>
<li id="menu-item-144137" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144137"><a href="/royalty-free-music/recent-tracks">Most Recent Music</a></li>
<li id="menu-item-144138" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144138"><a href="/royalty-free-music-genre/corporate">Corporate / Business</a></li>
<li id="menu-item-144139" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144139"><a href="/royalty-free-music-genre/jazz">Jazz Music</a></li>
<li id="menu-item-144140" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144140"><a href="/royalty-free-music-genre/classical">Classical Music</a></li>
<li id="menu-item-144141" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144141"><a href="/royalty-free">Royalty Free Music for Projects</a></li>
<li id="menu-item-144192" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144192"><a href="/music-collections">Music Collections</a></li>
<li id="menu-item-144194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144194"><a href="/free-music">Free Music</a></li>
</ul></div></li><li id="nav_menu-5" class="widget widget_nav_menu nav-block info"><h5 class="title">Info</h5><div class="menu-footer-area-3-container"><ul id="menu-footer-area-3" class="menu"><li id="menu-item-144142" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144142"><a href="/about">About Us</a></li>
<li id="menu-item-144143" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144143"><a href="https://www.premiumbeat.com/blog/testimonials/">Testimonials</a></li>
<li id="menu-item-144144" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144144"><a href="/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-144145" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144145"><a href="/license">License Agreement</a></li>
</ul></div></li><li id="nav_menu-6" class="widget widget_nav_menu nav-block composers"><h5 class="title">Composers</h5><div class="menu-footer-area-4-container"><ul id="menu-footer-area-4" class="menu"><li id="menu-item-144146" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144146"><a href="/new-artist">Submit Music</a></li>
</ul></div></li><li id="nav_menu-7" class="widget widget_nav_menu nav-block support"><h5 class="title">Support</h5><div class="menu-footer-area-5-container"><ul id="menu-footer-area-5" class="menu"><li id="menu-item-144147" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144147"><a href="/contact-us">Contact Us</a></li>
<li id="menu-item-144148" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144148"><a href="/faq">FAQ</a></li>
<li id="menu-item-144149" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144149"><a href="/cuesheets">Cue Sheets</a></li>
<li id="menu-item-144150" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144150"><a href="/blog/">Blog</a></li>
<li id="menu-item-144197" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-144197"><a href="/affiliates">Affiliate Program</a></li>
</ul></div></li>							</ul>
								<div class="nav-block nav-social">
										<div class="title">We’re Social</div>
										<div class="footer-share">
												<div class="social">
														<ul>
																<li><a href="https://www.facebook.com/premiumbeat" target="_blank"><span class="normal-rounded-icon icon">e</span></a></li>
																<li><a href="https://twitter.com/#!/premiumbeat" target="_blank"><span class="normal-rounded-icon icon">w</span></a></li>
																<li><a href="https://www.youtube.com/user/premiumbeat" rel="publisher" target="_blank"><span class="normal-rounded-icon icon"><i class="fa fa-youtube-play" aria-hidden="true"></i></span></a></li>
																<li><a href="https://www.instagram.com/premiumbeat/" rel="publisher" target="_blank"><span class="normal-rounded-icon icon"><i class="fa fa-instagram" aria-hidden="true"></i></span></a></li>
														</ul>
												</div>
										</div>
								</div>

						</div>
						<div class="footer-share">
							<div class="social">
									<ul>
										<li><a href="https://www.facebook.com/premiumbeat" target="_blank"><span class="normal-rounded-icon icon">e</span></a></li>
										<li><a href="https://twitter.com/#!/premiumbeat" target="_blank"><span class="normal-rounded-icon icon">w</span></a></li>
										<li class="btn-youtube"><a href="https://www.youtube.com/user/premiumbeat" rel="publisher noreferrer" target="_blank"><span class="normal-rounded-icon icon">√</span></a></li>
										<li class="btn-instagram"><a href="https://www.instagram.com/premiumbeat/" rel="publisher noreferrer" target="_blank"><span class="normal-rounded-icon icon">∫</span></a></li>
									</ul>
							</div>
						</div>
						<div class="footer-copy">
								<div class="footer-security">
										<div class="clearfix">
												<div class="inner">
														<img class="firstimg" alt="Master Card" src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/mastercard_inline.svg" width="146" height="26" loading="lazy">
														<img alt="Visa" src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/visa.svg" width="59" height="20" loading="lazy">
												</div>
												<div class="inner amex-discover">
														<img alt="Amex" src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/amex.svg" width="67" height="16" loading="lazy">
														<img alt="PayPal" src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/paypal.svg" width="79" height="21" loading="lazy">
												</div>
												<div class="inner ssl-certificate">
														<img class="medium-check" alt="SSL Certificate" src="https://vip-go.premiumbeat.com/wp-content/themes/thebeatcom/images/medium_check.svg" width="32" height="32" loading="lazy">
														<span>100<sup>%</sup> secure shopping</span>
												</div>
										</div>
								</div>
								<div class="footer-copyright">
										<span>PremiumBeat.com copyright © 2005-2022 <br />Shutterstock Music Canada ULC All rights reserved.</span>
								</div>
						</div>
				</div>
		</section>
</footer>
<div id="mm-blocker"></div>
		</div>  <!-- .wrapper -->
		<script type="text/javascript" src="https://vip-go.premiumbeat.com/_static/??/wp-content/themes/thebeatcom/js-dist/blog.min.js,/wp-includes/js/wp-embed.min.js?m=1641830756j" ></script><script data-cfasync="false" data-parsely-site="vip-go.premiumbeat.com" src='https://cdn.parsely.com/keys/vip-go.premiumbeat.com/p.js?ver=2.6.1' id="parsely-cfg"></script>
	<div id="fb-root"></div>
	<script>(function(d, s, id) {
			var js, fjs = d.getElementsByTagName(s)[0];
			if (d.getElementById(id)) return;
			js = d.createElement(s); js.id = id;
			js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=349870051765682";
			fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
	</script>
			<!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com-->
		<script
			type="text/javascript"
			src="https://a.optmnstr.com/app/js/api.min.js"
			data-account="2286"
			data-user="7191"
			async
		>
		</script>
		<!-- / OptinMonster -->
		<script src='https://stats.wp.com/e-202203.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.5',blog:'150422400',post:'162967',tz:'-6',srv:'vip-go.premiumbeat.com'} ]);
	_stq.push([ 'clickTrackerInit', '150422400', '162967' ]);
</script>
	</body>
</html>
